Changing Map Views While Using a Draw Menu Tool

 

If you need to zoom or pan the map view while drawing a polygon, it will need to be drawn in sections. The sections are then saved to a single file and edited to create the final polygon object. The process is as follows: Before you start drawing be sure to clear the drawing layer by drawing a bogus polyline of two or three points. Select Edit -> Select All Objects and then right-click on your polygon to delete it. This will also delete any other extraneous drawing objects that might not be visible.

  1. Choose Draw -> Polyline (NOT polygon)

  2. Draw the first portion of your boundary until you get to a place where you need to zoom in or change the map view. Double click the last point to complete this first portion of the boundary.

  3. Change your map view and then do Draw -> Polyline again and pick up drawing where you left off until you need to change the map view again. Double click the last point on this portion of the boundary.

  4. Repeat step 3 as needed until you have finished the boundary

  5. Choose Edit -> Select All Objects and then right-click on any part of the boundary and save to a BNA file.

  6. Edit the BNA file to remove all the intermediate "header" lines.

  7. Copy the first set of coordinates (line 2 in the file) and add them as the last line in the file.

  8. Update the "number of coordinate pairs" in the header line (item #3 in the first line).

  9. Save the file

Example: ORIGINAL FILE- "*EDX_Polyline*","",-4 -123.47095232543, 44.1578241698649 -123.387369195164, 44.2049531609573 -123.297375674056, 44.2296905512167 -123.190197632901, 44.2387290797219 "*EDX_Polyline*","",-3 -123.120295756283, 44.1840100764647 -123.086174049085, 44.1504912577566 -123.086206225509, 44.1510339310013 "*EDX_Polyline*","",-4 -123.082133799649, 44.1508951197063 -123.078254956834, 44.1494995228869 -123.077284956092, 44.1479638026066 -123.078835928218, 44.1468465872955

EDITED FILE- "*EDX_Polyline*","",12 -123.47095232543, 44.1578241698649 -123.387369195164, 44.2049531609573 -123.297375674056, 44.2296905512167 -123.190197632901, 44.2387290797219 -123.120295756283, 44.1840100764647 -123.086174049085, 44.1504912577566 -123.086206225509, 44.1510339310013 -123.082133799649, 44.1508951197063 -123.078254956834, 44.1494995228869 -123.077284956092, 44.1479638026066 -123.078835928218, 44.1468465872955 -123.47095232543, 44.1578241698649

 

For any additional questions regarding map views or using the draw menu tool, please submit a support ticket here: https://edxwireless.atlassian.net/servicedesk/customer/portal/2